Service degradation affecting API availability
Incident Report for ThousandEyes
Resolved
We are temporarily limiting the maximum date range supported for Alerts list API (/v6/alerts.json) from 90 days to 7 days

Alert list API results will be limited to a 7 day period irrespective of the date range requested, meaning an API request can pull past alerts but is limited to a range of 7 days worth of data. If an API call requests more than 7 days, the API response will return the first 7 days only

We will announce when this restriction is lifted
Posted Sep 22, 2022 - 20:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2022 - 20:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 22, 2022 - 19:40 UTC
Investigating
We are currently investigating a possible degradation to API services.

This notification will be updated in the event that platform health has been determined to be degraded.
Posted Sep 22, 2022 - 14:55 UTC
This incident affected: ThousandEyes Platform and API (API Availability).