Degraded performance on Endpoint Agent controller infrastructure
Incident Report for ThousandEyes
Resolved
This incident has been resolved.
Posted Oct 08, 2020 - 09:10 UTC
Monitoring
We have increased the capacity of the Endpoint check-in service and will continue to monitor the service.
Posted Oct 08, 2020 - 07:17 UTC
Identified
Endpoint Agent check-in and configuration update service has been fully restored. The root cause of the issue was due to scale and load.
Posted Oct 08, 2020 - 07:05 UTC
Update
We are continuing to investigate this issue.
Posted Oct 08, 2020 - 06:55 UTC
Update
Affected scope
Due to a capacity issue, Endpoint Agents will experience failures when attempting to check-in with the controller.
All existing Endpoint Agents tests will continue to run as normal. Any new tests or Endpoint settings are affected. We have identified the issue and are working to resolve the issue as quickly as possible.
Posted Oct 08, 2020 - 06:51 UTC
Investigating
We are currently experiencing degraded performance on our Endpoint Agent controller infrastructure.

Affected scope
Endpoint Agents may experience a failure when attempting to check-in with the controller.
Posted Oct 08, 2020 - 06:27 UTC
This incident affected: Agent Configuration and Data Collection (Endpoint Agents: Test assignment and configuration controller).