ThousandEyes Platform degraded performance
Incident Report for ThousandEyes
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 21:29 UTC
Monitoring
Endpoint agents are now submitting data and catching up. Our Operations team is monitoring the situation.
Posted Oct 19, 2020 - 18:47 UTC
Identified
Summary:
Endpoint Agent data services are partially unavailable. The ThousandEyes operations team is working towards a resolution.

Impact:
Endpoint Agents data reads are impacted by this issue. As a result, endpoint agent data is partially unavailable from dashboards, views, scheduled tests, and the API.

The Endpoint Agent controller (c1.eb.thousandeyes.com) is also impacted. During this outage Endpoint Agents will not be able to receive new scheduled test, label, or monitored domain assignments. The platform will report Agents as unseen during this outage, affecting the reported "last seen" time. New Endpoint Agents will not be able to complete the registration process during this time.

Endpoint Agent data submission is also affected by this service degradation. Agent data will be submitted to the platform as connectivity is re-established.

We do not anticipate any loss of Endpoint Agent data.
Posted Oct 19, 2020 - 17:12 UTC
Update
We are continuing to investigate this issue.
Posted Oct 19, 2020 - 16:52 UTC
Update
We are continuing to investigate this issue alongside the MongoDB team.
Posted Oct 19, 2020 - 16:40 UTC
Update
We are continuing to investigate this issue.
Posted Oct 19, 2020 - 15:38 UTC
Update
We are continuing to investigate this issue.
Posted Oct 19, 2020 - 15:36 UTC
Investigating
ThousandEyes Platform is currently experiencing degraded performance.

Affected scope
Due to degraded performance of ThousandEyes web servers, customers might notice increased page load times. Customers might see intermittent errors and delays on some app pages, and 500 response codes via API. Endpoint data and alerts may be delayed. Usage related requests are also affected and may not be available from the previous billing cycle.
Posted Oct 19, 2020 - 15:00 UTC
This incident affected: ThousandEyes Platform and API (Platform Availability, API Availability, Embedded Widgets) and Agent Configuration and Data Collection (Endpoint Agents: Data submission collector).