Service Degradation Affecting Dashboards Visualization in US2 Region

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 21:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 20:53 UTC

Identified

Summary
We are currently investigating a possible degradation impacting dashboards in US2 Region

Impact
Customers may experience delays in displaying data for dashboards in the US2 Region for the following sources:
Endpoint Agents - Dynamic Tests
Posted Jul 08, 2026 - 19:40 UTC
This incident affected: ThousandEyes Platform and API (Reports and Dashboards).