Difficulties when attempting to create new Organizations.
Incident Report for ThousandEyes
Resolved
The issue has been mitigated and verified as fixed
Posted Mar 14, 2024 - 00:04 UTC
Investigating
The operations team has encountered issues while creating new Organizations starting March 11 21:00 UTC. We are currently investigating this matter.
Posted Mar 13, 2024 - 19:33 UTC
This incident affected: ThousandEyes Platform and API (Configuration and Management).