Service degradation affecting Dashboards in US2 Region

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 16:44 UTC

Monitoring

Summary
We have identified an issue causing delays in displaying Endpoint Experience Local Network data within Dashboards in the US2 Region, beginning at 14:00 UTC.

Impact
Users may experience delays in data updates for dashboard widgets showing Endpoint Experience Local Network metrics.

Status
Our engineering team has applied a fix, and we are currently monitoring the environment to ensure full service restoration.
Posted Jul 21, 2026 - 15:05 UTC
This incident affected: ThousandEyes Platform and API (Reports and Dashboards).