Service Degradation Affecting Usage and Billing Service in US1 Region

Incident Report for ThousandEyes

Resolved

The incident has been resolved.
Posted May 29, 2025 - 11:44 UTC

Monitoring

A fix has been implemented and we're currently monitoring.
Posted May 29, 2025 - 11:10 UTC

Identified

The issue has been identified and the fix has been implemented.
Posted May 29, 2025 - 10:48 UTC

Investigating

The usage-service is having issues in US1 region. Customers may experience delays when navigating the Usage page, performing changes to CEA tests ( creating new tests or updating tests) or retrieving data via the Usage API endpoints. These issues are having cascading effects in other webapps services that depend on usage.
Posted May 29, 2025 - 10:30 UTC
This incident affected: Agent Configuration and Data Collection (Cloud and Enterprise Agents: Test assignment and configuration controller) and ThousandEyes Platform and API (Usage and Billing).