Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 01, 2023 - 18:01 UTC
Scheduled
Summary
The Alert and Integration Team will perform an API data type change to v6 and v7 API response payload of active alerts and alert details. As previously announced in our changelog, the data type of the alertID field will be changed from an integer to a string to accommodate the new 128-bit alphanumeric alert UUID. Changelog: https://docs.thousandeyes.com/whats-new/changelog#updating-alert-id-to-a-128-bit-alphanumeric-uuid-1
When: from 2023-05-01 18:00 UTC to 2023-05-01 23:00 UTC
Impact
In following Alert API endpoints, “alertId” filed in the response payload will change from an integer to a 128-bit alphanumeric alert UUID.
Please review any API scripts you use to pull alert data and make a plan to update the data type of the "alertID" field from an integer to a string by 4 pm PST on May 1st, 2023, especially if your scripts use strongly typed language.
ThousandEyes support is available to be of assistance 24 hours a day. Please open a chat from within app.thousandeyes.com or from status.thousandeyes.com to speak with a support engineer if you have any questions.
Posted Apr 06, 2023 - 21:45 UTC
This scheduled maintenance affected: ThousandEyes Platform and API (API Availability).