Service Degradation Affecting Alert Rules for Device Layer

Incident Report for ThousandEyes

Resolved

This incident has been resolved
Posted Jun 03, 2025 - 17:39 UTC

Identified

The issue has been identified and our engineering team is working on a solution
Posted Jun 03, 2025 - 16:28 UTC

Investigating

Summary
We have detected a service degradation that has been impacting the ability to update device layer alert rules in US1, US2 and EU regions since February. Our engineering team is actively working on a solution.
Posted Jun 03, 2025 - 16:13 UTC
This incident affected: Alerts and Notifications (Alert processing).