some users of mobile apps may be unable to execute speed tests.

Incident Report for ThousandEyes

Resolved

This incident has been resolved
Posted Mar 31, 2026 - 08:25 UTC

Identified

Due to a platform issue some users of mobile apps may be unable to execute speed tests.
our team has identified the root cause and are actively working on this issue for resolution
Posted Mar 31, 2026 - 08:01 UTC
This incident affected: Connected Devices (Formerly SamKnows).