Investigating possible degradation of the Support Page

Incident Report for ThousandEyes

Monitoring

ThousandEyes Engineering has remediated the issue for customers accessing the Contact Support page. Functionality is restored and we will continue to monitor.
Posted Aug 25, 2026 - 23:47 UTC

Identified

We have identified the issue preventing access to the Contact Support page. ThousandEyes Engineering is actively deploying a fix to affected regions.
Posted Aug 25, 2026 - 23:33 UTC

Update

We are continuing to investigate this issue.
Posted Aug 25, 2026 - 19:42 UTC

Investigating

Customers may encounter an error when accessing the Contact Support page within the ThousandEyes application.
ThousandEyes Engineering teams are investigating the issue.
Please send an email to our Support team at support@thousandeyes.com to open a new case
Posted Aug 25, 2026 - 09:00 UTC
This incident affects: ThousandEyes Platform and API (Platform Availability, Customer Success Chat).