Service Degradation Affecting Endpoint Agent Schedule Test Data in US1 Region

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 19:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 17:41 UTC

Update

Our team is currently backfilling the data and working to restore full service.
Posted Apr 07, 2026 - 15:55 UTC

Identified

Summary:
We have identified an issue causing delays in Endpoint Agent Scheduled Test data in the US1 Region, beginning at 14:00 UTC on April 7th, 2026.

Impact:
Customers may experience delays in the US1 Region Endpoint Agent Scheduled Test Data. This may be seen in the following Endpoint Agent areas: Agent Views, Views, Alerts, Dashboards, or API.

Status:
Our Engineering Team is actively investigating the issue and working toward a resolution.
Posted Apr 07, 2026 - 15:07 UTC
This incident affected: Alerts and Notifications (Alert processing), ThousandEyes Platform and API (Reports and Dashboards, Endpoint Agent Views), and Agent Configuration and Data Collection (Endpoint Agents: Data submission collector).