Service Degradation impacting Endpoint Experience tab in the web app

Incident Report for ThousandEyes

Resolved

We have confirmed that access to the Endpoint Experience tab is working as usual.
Customers may have suffered impacts around 22:20UTC - 23:58 UTC.

ThousandEyes Support is available 24/7. If you need assistance or have any questions, feel free to open a case with us by sending an email to support@thousandeyes.com or opening a live chat session to speak with an engineer from within app.thousandeyes.com.
Posted Mar 10, 2026 - 00:50 UTC

Monitoring

We have implemented a fix and are currently monitoring the results
Posted Mar 10, 2026 - 00:15 UTC

Update

We are continuing to investigate this issue.
Posted Mar 09, 2026 - 23:59 UTC

Investigating

We have identified an issue where customers in the US1 region may have issues when opening pages under Endpoint Experience on the ThousandEyes Platform. Customers may experience a 500 error page when accessing pages grouped under Endpoint Experience.
Service degradation started around 23:00 UTC.

Our team is currently investigating and we will be providing an update soon.
Posted Mar 09, 2026 - 23:58 UTC
This incident affected: ThousandEyes Platform and API (Endpoint Agent Views).