Service Degradation affecting Traffic Insights Page

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 09:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2025 - 00:57 UTC

Update

We are continuing to investigate this issue.
Posted Nov 12, 2025 - 00:38 UTC

Investigating

At around 10:30 pm UTC, 11th Nov 2025, we observed traffic insights page failed to load in US region. Customer might experience issue viewing the traffic insights page.
Posted Nov 12, 2025 - 00:36 UTC
This incident affected: ThousandEyes Platform and API (Platform Availability).