Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 02, 2025 - 17:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 01, 2025 - 19:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 01, 2025 - 19:27 UTC
Scheduled
ThousandEyes team will be performing a maintenance window for EU region.
Start time: 2025-12-02 17:00:00 UTC End time: 2025-12-02 18:00:00 UTC
Anticipated Impact:
Usage reporting may be unavailable, usage events may experience a delay. The agent offline graph shown under Agent Statistics may not be fully consistent during this period.
Internet insights: During maintenance window, network and application outages may be missed and/or incomplete, historical network and application outages may not be available, trials and new customer updates may be delayed
Workaround: None
ThousandEyes support is available to be of assistance 24 hours a day. Please open a chat from within app.thousandeyes.com to speak with a support engineer or send an email to support@thousandeyes.com if you have any questions
Posted Nov 24, 2025 - 23:11 UTC
This scheduled maintenance affected: ThousandEyes Platform and API (Platform Availability, API Availability) and Internet Insights collection and processing.