Service Degradation Affecting Internet Insights Application Outages

Incident Report for ThousandEyes

Update

We are continuing to investigate this issue.
Posted Sep 24, 2026 - 21:13 UTC

Investigating

Summary
The Internet Insights “Views” timeline is unresponsive and/or not displaying the topology of recent application outages.

Status
Our engineering team is actively working to resolve this issue. We will provide updates as soon as more information becomes available.
Posted Sep 24, 2026 - 18:12 UTC
This incident affects: Internet Insights collection and processing.