Service Degradation Affecting Usage and Billing Service

Incident Report for ThousandEyes

Resolved

There was no degradation or interruption to services, as verified in our initial assessment.
Posted Jul 31, 2025 - 21:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2025 - 20:59 UTC

Investigating

Status
We are currently investigating

Customer impact
Starting on July 29th at 20:19 UTC due to an increased delay in processing agent-related changes customers' projections and usages aren't updated in a timely manner allowing them to cross their quota and contract limits when creating and/or modifying tests, especially when the modifications include agent both cloud and enterprise assignments.

Status
Our Engineering Team is actively working on a solution.
Posted Jul 30, 2025 - 18:43 UTC
This incident affected: ThousandEyes Platform and API (Usage and Billing).