Service Degradation affecting Endpoint agent Geolocation
Incident Report for ThousandEyes
Resolved
The Endpoint Agent geolocation service has been restored
Posted May 12, 2022 - 15:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2022 - 14:35 UTC
Identified
- Geolocation Services is crashing and causing the the high check-in time for Endpoint agents
- ThousandEyes Engineering team has disabled the Endpoint agent geolocation services temporarily at 2022-05-12 00:05 UTC
- Endpoint agent check-in time is back to normal
- Endpoint agent team is investigating the geolocation services

Service Impact: Endpoint agents will use the geolocation of the assigned IP addresses instead of the Google API services , and this might cause inaccurate locations for Endpoint Agents
Posted May 12, 2022 - 00:46 UTC
Investigating
Endpoint agent controller encountered a high check-in time for Endpoint agents
Incident Start time: 2022-05-11 22:58:23 UTC
Posted May 12, 2022 - 00:36 UTC
This incident affected: Agent Configuration and Data Collection (Endpoint Agents: Test assignment and configuration controller).