Service Degradation affecting Dashboards and Usage & Billing in US1 Region

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 16:57 UTC

Monitoring

Summary:
We identified an issue affecting the loading of Dashboards and the Usage and Billing pages in the US1 Region, from 15:56 to 16:15 UTC on March 12, 2026.

Impact:
Customers may have experienced unavailability or encountered errors when navigating to these specific pages within the US1 Region.

Status:
Our engineering team has applied a fix, and all services have been restored to normal operation.
Posted Mar 12, 2026 - 16:21 UTC
This incident affected: ThousandEyes Platform and API (Reports and Dashboards, Usage and Billing).