Service degradation affecting embedded data.

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 18:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2026 - 18:43 UTC

Investigating

We identified the issue with the embedded widgets starting on Tuesday, March 3rd, 15:00 UTC.

Customers may experience 429 HTTP errors while navigating to sites that have ThousandEyes embedded widgets on them.

We are currently investigating.
Posted Mar 04, 2026 - 18:28 UTC
This incident affected: ThousandEyes Platform and API (Embedded Widgets).