Cloud and Enterprise Agent data is correctly ingesting without delays. All services are operating normally and we continue to monitor.
Posted Jul 15, 2026 - 23:59 UTC
Update
Cloud and Enterprise Agent data continues to be intermittently delayed for visualization, API, and alerting. We are continuing to investigate and work on mitigation.
Posted Jul 15, 2026 - 23:25 UTC
Update
We are continuing to investigate this issue.
Posted Jul 15, 2026 - 22:53 UTC
Update
We are continuing to investigate this issue.
Posted Jul 15, 2026 - 22:52 UTC
Investigating
Starting 22:10 UTC we have identified a hardware issue in the EU region causing issues receiving and displaying data for Cloud and Enterprise Agent tests. Our team is investigating and working on remediation. Alerts and visualization of data may be delayed
Posted Jul 15, 2026 - 22:51 UTC
This incident affected: Alerts and Notifications (Alert processing, Notification dispatching, Webhook and Integrations, Email notifications) and ThousandEyes Platform and API (API Availability, Test data availability, Configuration and Management, Usage and Billing).