Service Degradation Affecting Alerting Services in EU Region

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 17:20 UTC

Update

Our engineering team has identified a potential fix and is actively working on its implementation.
Posted Jun 25, 2025 - 22:10 UTC

Update

We are no longer observing delays in alert delivery. Our engineering team continues to investigate the root cause of the incident to determine the appropriate fix.
Posted Jun 25, 2025 - 19:45 UTC

Update

We are currently observing that the delays are decreasing. Our engineering team continues to investigate the root cause of the incident to plan an appropriate fix.
Posted Jun 25, 2025 - 17:59 UTC

Update

We are continuing to work on mitigating this issue.
Posted Jun 25, 2025 - 17:18 UTC

Identified

Summary:
We observed delays in alert dispatching starting at 11:30 UTC on June 25th.

Impact:
Customers may experience delays in the triggering or clearing of alerts related to Scheduled Tests on Endpoint Agents.

Status:
Our engineering team is actively working to resolve the delays.
Posted Jun 25, 2025 - 14:41 UTC
This incident affected: Alerts and Notifications (Alert processing, Notification dispatching, Webhook and Integrations, Email notifications).