Investigating possible service degradation for SamKnows Metadata API

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Mar 09, 2025 - 09:14 UTC

Monitoring

We have observed that the availability is back to 100% as of 8.13am UTC.
Posted Mar 09, 2025 - 08:35 UTC

Identified

We have identified the root cause to be some very old agents having a bug with handling DST changes causing them to restart (and DST just switched in the US this morning).
The customer were given upgraded agents long ago, but we suspect that they haven't upgraded them all yet.
Posted Mar 09, 2025 - 08:32 UTC

Investigating

We have observed a drop in the availability and an increase in the latency for the external Metadata API for Samknows.
Incident start: 6:52 UTC
Posted Mar 09, 2025 - 08:29 UTC
This incident affected: ThousandEyes Platform and API (API Availability) and Samknows.