DNS Resolver Issues on Cloud Agents in China

Incident Report for ThousandEyes

Monitoring

We applied configuration changes that fixed the issue and are monitoring the situation
Posted May 30, 2026 - 13:39 UTC

Identified

We are currently experiencing DNS resolution issues on Cloud Agents across China, specifically affecting Alibaba Cloud Public DNS.
We are working on a resolution
Posted May 30, 2026 - 12:10 UTC
This incident affects: Agent Configuration and Data Collection (Cloud and Enterprise Agents: Data ingress) and Cloud Agents: Asia Pacific (Alibaba Cloud: APAC).