Enterprise Agents and Cloud Agents fail on check in between 18:47-18:53 UTC
Incident Report for ThousandEyes
Resolved
Some Enterprise and Cloud Agents could not contact the ThousandEyes Agent controller during the service degradation.

Affected scope:
Some Enterprise and Cloud Agents were marked as "Offline" during this period. There was no observed impact on data collection and submission from Agents. New configurations made were not propagated during this period.

Status:
The issue has been resolved.

Event timeline:
2020-07-10 18:47 UTC Start of check-in failure
2020-07-10 18:53 UTCCheck-in restored.
Posted Jul 10, 2020 - 23:49 UTC
Investigating
Between 18:47-18:53 UTC, we observed some Enterprise and Cloud Agents fail to complete the check-in process, causing these Agents to be marked as "Offline". The Operations team is investigating the root cause of this issue. There was no observed impact on data collection and submission from Agents. New configurations made were not propagated during this period.
Posted Jul 10, 2020 - 20:09 UTC
This incident affected: Agent Configuration and Data Collection (Cloud and Enterprise Agents: Registration controller, Cloud and Enterprise Agents: Test assignment and configuration controller, Cloud and Enterprise Agents: Data ingress), ThousandEyes Platform and API (Platform Availability, API Availability, Test data availability), and Alerts and Notifications (Alert processing, Notification dispatching).