Error when accessing Contact Support Page

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 06:02 UTC

Identified

We are currently experiencing issues with the Contact Support page in the US1 Region

Our engineering team is actively working on a fix.

In the meantime, if you need to open a case, please email us at support@thousandeyes.com or use the "Chat with Support" option to start a conversation with an engineer.
Posted Jul 22, 2025 - 22:42 UTC

Update

The ThousandEyes team will be performing maintenance on the Support case page for users in US1. New case creation from the "Contact Support" menu may be impacted during this time, from 20:15 UTC to 20:45 UTC.

If you need to open a case, please send an email to support@thousandeyes.com
Posted Jul 22, 2025 - 20:15 UTC

Update

The ThousandEyes team will be performing maintenance on the Support case page for users in US2. New case creation from the "Contact Support" menu may be impacted during this time, from 19:15 UTC to 20:15 UTC.

If you need to open a case, please send an email to support@thousandeyes.com or use the "Chat with Support" menu to open a new chat with an engineer.
Posted Jul 22, 2025 - 19:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 05:46 UTC

Investigating

Customers may encounter an error when accessing the Contact Support page within the ThousandEyes application.
ThousandEyes Engineering teams are investigating the issue.
Please send an email to our Support team at support@thousandeyes.com to open a new case.
Posted Jul 17, 2025 - 04:01 UTC
This incident affected: ThousandEyes Platform and API (Customer Success Chat).