Service degradation affecting Usage and Billing service in US1 region

Incident Report for ThousandEyes

Resolved

This incident has been resolved
Posted Apr 11, 2025 - 00:05 UTC

Update

We are continuing to monitor for any further issues
Posted Apr 10, 2025 - 21:01 UTC

Monitoring

Service Degradation affecting usage events in US1 region


Between 6:00 UTC and 17:05 UTC on April 10th, some customers in the US1 region may have seen incorrect usage data and usage projections in the product.

Status:
The issue has been identified and a fix is being implemented
Posted Apr 10, 2025 - 17:23 UTC
This incident affected: ThousandEyes Platform and API (Usage and Billing).