Service Degradation Affecting Endpoint Agents Scheduled Test Data and Alerts in US1 Region

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 17:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2025 - 16:40 UTC

Identified

Summary:
We observed delays in Scheduled Test data and alert processing for Endpoint Agents starting at 14:00 UTC on June 26th.

Impact:
Customers may experience delays when displaying data in the Endpoint Experience Views page, Dashboards, or in the triggering and clearing of alerts related to Scheduled Tests on Endpoint Agents.

Status:
Our engineering team is actively working to resolve the delays.
Posted Jun 26, 2025 - 15:34 UTC
This incident affected: Alerts and Notifications (Alert processing, Notification dispatching, Webhook and Integrations, Email notifications) and ThousandEyes Platform and API (Reports and Dashboards).