Service degradation affecting Event Detection in US2 Region

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 23:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 22:03 UTC

Identified

Summary:
We have identified an issue causing delays in detecting new events within the Event Detection service in the US2 Region, beginning at 17:20 UTC on March 17, 2026.

Impact:
Customers may experience delays in event detection for Network and App Synthetic Tests.

Status:
Our engineering team is actively working in resolving this issue.
Posted Mar 17, 2026 - 19:52 UTC
This incident affected: ThousandEyes Platform and API (Event Detection).