Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 18, 2025 - 20:00 UTC
Scheduled
Description:
The ThousandEyes team will perform a maintenance window on December 18th 2025. This maintenance will impact only US2 region.
Start time: 2025-12-18 20:00:00 UTC End time: 2025-12-18 23:00:00 UTC
Impact: Dashboards real-time data may be impacted for up to 1 hour for some widgets during this maintenance window. Users will observe the following behavior:
-Duplicate or incorrect aggregated data in Dashboard widgets for the latest 1 hour only -Widgets with following data sources will only be impacted:
ThousandEyes support is available to be of assistance 24 hours a day. Please open a chat from within app.thousandeyes.com to speak with a support engineer or send an email to support@thousandeyes.com if you have any questions
Posted Dec 15, 2025 - 21:07 UTC
This scheduled maintenance affected: ThousandEyes Platform and API (Reports and Dashboards).