Customers are unable to create, edit Tests or access dashboards across all regions

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 02:36 UTC

Monitoring

At 2:13 UTC Match 12 the issue has been identified and mitigated, and all the services now are up and running
Posted Mar 12, 2025 - 02:34 UTC

Investigating

Starting at 1:27 UTC March 12th, customers are unable to create or edit tests, as well as view test results in dashboards and widgets in all regions. The ThousandEyes Engineering team has identified the issue and is working on resolution.
Posted Mar 12, 2025 - 02:11 UTC
This incident affected: ThousandEyes Platform and API (Reports and Dashboards, Configuration and Management).