Salesforce down for maintenance, hence tech support is currently offline until further notice.

Incident Report for ThousandEyes

Resolved

This Salesforce issue has been resolved and we are back online ready to take support cases and chats.
Posted Mar 17, 2026 - 06:29 UTC

Investigating

A service disruption with SalesForce is currently impacting the availability of chat and email support. For urgent issues, please email support@thousandeyes.com for manual case assignment.
Posted Mar 17, 2026 - 04:11 UTC
This incident affected: ThousandEyes Platform and API (Customer Success Chat).