Service Degradation Affecting the ThousandEyes Web Application

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 19:43 UTC

Monitoring

Summary:
We observed an issue with the ThousandEyes Web Application between 19:08 UTC and 19:21 UTC across all regions.

Impact:
Customers may have experienced delays or temporary unavailability while accessing or loading the ThousandEyes web application.
• US1 and US2 were impacted between 19:08 UTC and 19:21 UTC.
• EU was impacted between 19:09 UTC and 19:21 UTC.

Status:
Our Engineering team has applied a fix and is actively monitoring the service to ensure full resolution.
Posted Feb 18, 2026 - 19:37 UTC
This incident affected: ThousandEyes Platform and API (Platform Availability).