Service Degradation Affecting Logins in EU Region

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Aug 22, 2026 - 01:23 UTC

Monitoring

Monitoring confirms the fix has been successful and users can login. We will continue to monitor.
Posted Aug 21, 2026 - 09:00 UTC

Identified

A fix has been implemented and we are seeing signs of recovery. We are monitoring the results.
Posted Aug 21, 2026 - 08:35 UTC

Investigating

Starting at 07:15 UTC, some users in the EU1 region are unable to login. API requests are unaffected.
We are investigating the issue
Posted Aug 21, 2026 - 08:19 UTC
This incident affected: ThousandEyes Platform and API (Platform Availability).