Service Degradation Affecting Support Case Creation

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 15:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2026 - 04:20 UTC

Identified

Customers may encounter an error when attempting to open support tickets through the web application. As a workaround, please submit technical support cases via email at support@thousandeyes.com or through the chat.

Our team is currently working on a fix.
Posted Jun 23, 2026 - 22:10 UTC