Connected Devices Agent Availability Issues in EU Region

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 16:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2026 - 16:46 UTC

Identified

Summary:
An issue impacting connected device agent availability in the EU Region began at 15:02 UTC.

Impact:
Triggered tests and two-step Real Speed Tests may be affected. Currently, a small number of agents are disconnected from the trigger-testing platform. Scheduled testing remains unaffected.

Status:
Our engineering team is currently working in restoring the service.
Posted Jun 08, 2026 - 16:30 UTC

Investigating

We are investigating platform degradation for connected devices agents to determine if users are experiencing an issue with the agents.
Posted Jun 08, 2026 - 16:23 UTC
This incident affected: Agent Configuration and Data Collection (Connected Devices Test Assignment).