Service degradation affecting Cloud and Enterprise Agents Tests Settings

Incident Report for ThousandEyes

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 17:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2025 - 17:01 UTC

Update

Customer should see improvement of creation and update with the network and application synthetics test but certain organizations may still see latency issues. We are continuing with the restoration with a more permanent fix.
Posted Jun 10, 2025 - 15:47 UTC

Identified

We are continuing to observe issues with Cloud and Enterprise Agents (CEA) test creation and updates. The investigation is ongoing.
Posted Jun 10, 2025 - 14:21 UTC

Update

We need to push some changes; this will impact all customers for 10 minutes.
Endpoint customers won’t be able to register agents, and CEA customers’ test creation and updating flow will be affected.
Posted Jun 10, 2025 - 13:15 UTC

Update

We continue to investigate the issue.
Posted Jun 10, 2025 - 12:47 UTC

Investigating

Some customers are experiencing issues with creating and updating CEA tests.
We are currently investigating this issue.
Posted Jun 10, 2025 - 10:32 UTC
This incident affected: Agent Configuration and Data Collection (Cloud and Enterprise Agents: Test assignment and configuration controller).