Service Degradation Affecting Test Views Load Times

Incident Report for ThousandEyes

Resolved

This incident has been resolved
Posted Aug 08, 2026 - 14:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2026 - 22:39 UTC

Identified

Our engineering team has identified the cause of the issue and is planning to release a fix as soon as possible.

ThousandEyes support is available 24 hours a day. Please open a chat from within app.thousandeyes.com to speak with a support engineer, or email support@thousandeyes.com if you have any questions.
Posted Jul 27, 2026 - 15:53 UTC

Investigating

Customers may experience delays loading Multi-Test Views data for Network and App Synthetics tests. Our engineering team is actively investigating and working to resolve the issue.
Posted Jul 24, 2026 - 16:55 UTC
This incident affected: ThousandEyes Platform and API (Platform Availability, API Availability, Test data availability).